Autor Thema: ruby 1.8.7 für HPUX  (Gelesen 3791 mal)

Offline landy

  • Unix Master
  • ****
  • Beiträge: 298
    • Profil anzeigen
ruby 1.8.7 für HPUX
« am: 15. November 2008, 22:16:38 »
Ich konnte Ruby 1.8.7 aus ftp://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.7.tar.gz mit aCC für HPUX übersetzen.
Bis auf eine Kleinigkeit läuft das Ding durch.
Wichtig: wenn bei "make" der Fehler kommt:

/usr/local/src/ruby-1.8.7/lib/mkmf.rb:8: uninitialized constant Config (NameError)
        from ./ext/extmk.rb:37:in `require'
        from ./ext/extmk.rb:37
*** Error exit code 1


dann rbconfig.rb mit vi öffnen und wieder speichern. Vermutlich wird dabei CR/LF oder so was umgebaut, auf jeden Fall wird das File kleiner.
Dafür läuft "make", "make test", "make install" nun absolut ordentlich durch. Merkwürdig  ???

Ein Binär-tar.gz hab ich auch mal auf meinen Server gelegt, keine Garantie dass es funzt: http://www.landycom.de/hpux/ruby-1.8-bin.tar.gz

Grüße,
Michael

unixforum.net - Der Treffpunkt für UNIX Fans

ruby 1.8.7 für HPUX
« am: 15. November 2008, 22:16:38 »

Offline alix

  • Unix Guru
  • *****
  • Beiträge: 1174
    • Profil anzeigen
Re: ruby 1.8.7 für HPUX
« Antwort #1 am: 15. November 2008, 23:15:34 »
Danke!!